Password link too old

Not being deliberately troublesome, really!

Just tried logging in from another machine which hadn’t memorised my password, so requested a password reset. When I clicked on the reset link it came up with a message that the link was too old. I’ve tried three times and it keeps repeating the same error message.

Thanks - I’ll get Feral to look into it.

This thread has some ideas:

Much rather techie (not difficult, but you need admin permissions), but one that seems possible is checking your computer’s internal clock / time zone, as per message 9 on that thread

1 Like

Assuming Marjorie’s computer’s clock is vaguely right, I strongly suspect that this has the same cause as the “no image uploads” problem – the Apache front-side proxy on the server. A move to a dedicated server should fix this.

I was hoping we wouldn’t need to do that until we had about 250 users, but if it has to be, I suspect it has to be. And possibly better done now, when there are fewer of us to be discommoded by the move…

That will presumably entail a cost? I’m happy to contribute a few bob; I’m sure others will feel the same. As you say, better to bite the bullet than keep running into issues that garner the site a reputation for being buggy and problematic.


I expect eventually F’Techie will organise a paypal account or something – cross wood and touch fingers we don’t have any problem about not being able to be paid money because it would mess up our benefits, which makes life easier – but I feel that this project ought not to start with its hand out. Let’s see how it goes; I can afford to run it for a year or so, and then if it is a complete frost, well, I can simply give up, and if it is a success we can work out some way for people who want to to contribute.

Has the move to a dedicated server solved the two problems?